🌳 General

πŸ› Installation

🐞 Alternative way (via pip)

EOmaps is also available via pip and can be installed using

pip install eomaps

However, it is not guaranteed that all dependencies are correctly resolved and some manual tweaking of the environment might be required to ensure that all packages work as expected.

A list of the dependencies can be found below:

dependencies:
  - python >=3.7
  - rtree
  - numpy
  - scipy
  - matplotlib >=3.0
  - cartopy >=0.20.0
  - descartes
  - mapclassify
  - pyproj
  - pyepsg
  # -------------- for WebMaps
  - owslib
  - requests
  - xmltodict
  - cairosvg
  # -------------- optional
  - pandas
  - geopandas
  - datashader
  - xarray
  - rioxarray
  # -------------- for building the docs
  - sphinx
  - sphinx-copybutton
  - sphinx_rtd_theme
  - mock
  # -------------- for Equi7Grid projections
  - pip
  - pip:
    - equi7grid